• home
  • HoloEdit Basics

HoloEdit Basics

License And Account

../_images/login.png

HoloEdit requires a HoloEdit License to process Stages and access the compute server. When signed in to an account with a valid license, you may acquire or release your license using the “Acquire” or “Release” button to the right of the License Type text in the User Profile Window. Access the User Profile window from User -> Manage Profile on the Menu Bar.

Workspaces

All work in HoloEdit is performed in Workspaces. A Workspace is a folder on your computer where HoloEdit stores Clips, Compositions, and other data necessary to edit volumetric video. Any files placed in your Workspace directory will be automatically detected inside HoloEdit, and supported mesh and texture files can be imported as Clips.

Choosing a Workspace

Upon first launching HoloEdit, or any other time by choosing “File > Open Workspace”, you must choose a workspace to use for your work in HoloEdit. Pressing the “Open Workspace” Button will launch the “Select Workspace” file browser. The specified folder will be used as your workspace.

You should always create a new empty folder to use as your workspace. All files and subfolders in the specified workspace will be indexed by HoloEdit and have corresponding .meta files created. It is not recommended you add an existing folder (such as “My Documents”) as a HoloEdit workspace.

Dockable Panels

The HoloEdit UI is made out of dockable, scalable panels for each of the major Panel types – Inspector, Project, Composition, and Viewport. To scale a pane, mouse over the border between it and another adjacent pane, and click and drag from the “Tab” at the top left of the pane, then drop on the edge of another pane to dock beside it, or the center of any pane to dock as a tab.

To close a pane, click and drag it out of the HoloEdit UI.

Closed windows can be restored from the Window option in the Menu Bar. If a window is already open, its option in the Window menu will appear greyed out.

Tooltips

Many pieces of the HoloEdit UI provide instructional tooltips on mouse hover. Playback controls, Timeline and Track editor buttons, and various Stage settings feature descriptive tooltips.

Workspace Management

After creating a workspace in HoloEdit, the workspace directory will be populated with a vol directory and a project.info file. These files are automatically generated and maintained by HoloEdit, and opening or editing them may render your workspace unusable.

Opening And Closing Workspaces

To switch workspaces, you can use the Open Workspace button in the File menu, and select any non-workspace folder to create a new workspace, or an existing workspace directory to open that workspace. Closing or opening a new workspace will delete any unsaved changes in your current Composition. Tracks, intervals, and job-results are stored on the Composition, so be sure to save your Composition before closing a workspace.

.Meta Files

In addition, HoloEdit will detect and generate .meta files for any files and folders that you add to the Workspace. The files are used internally by HoloEdit to keep track of your files in the Project.

Generally, you shouldn’t interact with .meta files, and you should only interact with the Workspace Directory in the following ways:

  • To add data , move or paste that data into the Workspace directory, or a subfolder outside of /vol

  • To update files or Clips , copy and overwrite the related files or folders

  • To remove a Clip , delete the Clip’s folder and all of its contents.

  • Removing individual files within a Clip isn’t recommended, but can be achieved by deleting individual files and their corresponding .meta files.

  • When moving or renaming a file , move or rename the .meta file as well

.Clip Files

When a user creates a Clip, a .clip file is automatically generated within the Clip directory. Users should take care not to move or delete a .clip file except when deleting the entire Clip directory.

Non-Clip Folders

The most common way to interact with Folders in HoloEdit is by using them to create Clips. However, for more complicated projects, you may want a more complicated file tree. In HoloEdit 2021.1, folders that don’t represent Clips will be greyed out in the project view, but can be navigated normally. This way, you can nest Clips within subdirectories by creating child folders and pressing the “Make Clip” button on those folders.

The Project View

../_images/workspace.png

The Project View , in the bottom right of the default HoloEdit layout, displays the Project hierarchy – HoloEdit’s display of the Clips, Compositions, and data ready for import within the workspace. The Project View shows: Folders, Files, Clips, and Samples.

Clips

Some Folders can be converted into Clips. Folders containing Source Data that can be imported as a Clip (supported input formats such as .obj, .png, etc) will have a “Make Clip” button on the right side, which can be used to create a Clip.

Clips are similar to folders, but when selected will display the Clip information in the Inspector window. Individual files (or, samples) within Clip folders can be inspected in the same way.

See Creating a Clip for more details on creating and using Clips.

While an Import is in progress, the space in the Project panel containing the clip will gradually fill with a green bar to indicate the clip import progress.